PDA

View Full Version : Help 86 Prostar!!!


prostar79
06-14-2008, 11:08 AM
I am fed up with this boat!! 1986 prostar with Ford 351W. I just pulled it out after the winter and it will not start. It ran fine when put away for the winter last year. I have replaced the coil,igniter, spark plugs. The engine cranks and cranks but will not start up. There is spark, fuel and the timing is fine. So what would make it not start. Spark and Fuel should start it, shouldn't it? I have poured ether into the carb (I know your not supposed to do this) and still nothing. Is there any electrical switches that would make it not start? Any help would be greatly appreciated!! It is warming up and I am getting frustrated!!!!

sk8salomon
06-14-2008, 11:40 AM
do you know for sure it is getting spark? pull one of the plugs out and ground to the block while turning the engine over. are all 8 cylinders getting spark? By "igniter" do you mean the upgraded igniter for points & condensor or do you mean the rotor button? How old is the distributor cap? Is the dead-man switch functioning correctly?

kingu
06-16-2008, 10:43 AM
mine did the same thing last year, sanded the points and started right up.

Prostar Rich
06-16-2008, 11:12 AM
As mentioned in previous posts are you sure that you are getting spark? Not sure if a 86 PS has a safety kill switch however if you are not getting spark and you have a safety kill switch take a look at the kill switch. The kill switch is a known problem. Second are sure you are getting fuel? If not fuel pump may be bad. Mine went out last season when I dewinterized the boat and attempted to start it. With a starting issue it really comes down to the process of elimination.

Good luck,
Prostar Rich