PDA

View Full Version : Helllp!


87MCProstar
06-04-2008, 04:28 PM
I am still trying to get new motor started. Last weekend I wasn't getting any spark, so I picked up another new coil and a new ignition module of the dizzy. They came today ups from skidim and disconnected reconnected and still nothing. Motor is just cranking over, just begging to be started. But still nothing. Another thing is when I'm cranking the key the oil pressure gauges pegs and it doesn't go back to zero until after the key is in the 'off' position for a couple of secs. Can anyone help me here???

454Prostar190
06-04-2008, 04:37 PM
IMO It sounds like you have a ground wire issue somewhere.

djhuff
06-04-2008, 04:53 PM
If you're not getting spark, I would start with a fluke to find your problem, figure out why there is no power, fix that, then start replacing parts.

I agree in the grounding issue.

TRBenj
06-04-2008, 06:28 PM
Tim, how are you determining that youre not getting spark? The easiest way is to pull a plug wire off, insert a spare spark plug into the wire, and hold the ground strap to a good ground (like the block). You'll be able to see and hear the spark if you have one.

If you truly have no spark, then check your voltage at the + side of the coil. Using a voltmeter, the + (red) goes to the + of the coil, the - (black) goes to a good ground (clean bolt on the block or intake). If your ballast resistor is bypassed, you should have 12V with the key on. If you havent bypassed the resistor, you should see 9-10V.

If you dont have voltage at the coil, then thats your problem and you need to figure out why. Trace it back to find out where you lose it (go from coil --> BR--> NSS --> safety lanyard --> ignition switch).

If you do have good voltage to the coil, then the problem lies in the coil itself, the dist, or the connections between them. The Prestolite EI kit should be hooked up with the purple wire to the + side of the coil, and the black wire to the - side. Remove the tach wire from the coil (also on the - side) as Ive heard that a bad tach can backfeed and cause funky ignition symptoms. Also check the condition of the cap and rotor- are they clean? Are they the proper parts and is there evidence that theyre making proper contact?

If you determine that you have fuel and spark but it still wont kick, reinspect the firing order and double check your timing. The rotor should just about point to the tower connected to cyl # 1 when the timing marks on your harmonic balancer is at TDC (or actually just before it).

Chief
06-04-2008, 07:47 PM
Start simple, check the lanyard switch. If you have too take the lanyard switch out and check operation with multimeter to see if switch is working.

87MCProstar
06-04-2008, 09:03 PM
okay, thanks tim. I really appreciate the help and i am sorry to keep bothering you, but i'm come to the end of my rope with patience, its the end of school summer coaching is in full swing, and i also took on another full time job. so needless to say i'm jonesing for the boat to being running so i can relax.

As far as the lanyard switch, my boat didn't come with one when I bought it. So i'm assuming it was/is bypassed somehow, since the boat worked until i had the bright idea to have work done. i'll check with my uncle this weekend to c if he has time to look at it since i'll spend 36 hours sat and sun inside at a pool for a meet :-(.

Thanks again for you help everybody...its nice a dumb@$$ like myself can come on here and getting extremely helpful information.

Tim

Chief
06-04-2008, 09:49 PM
okay, thanks tim. I really appreciate the help and i am sorry to keep bothering you, but i'm come to the end of my rope with patience, its the end of school summer coaching is in full swing, and i also took on another full time job. so needless to say i'm jonesing for the boat to being running so i can relax.

As far as the lanyard switch, my boat didn't come with one when I bought it. So i'm assuming it was/is bypassed somehow, since the boat worked until i had the bright idea to have work done. i'll check with my uncle this weekend to c if he has time to look at it since i'll spend 36 hours sat and sun inside at a pool for a meet :-(.

Thanks again for you help everybody...its nice a dumb@$$ like myself can come on here and getting extremely helpful information.

Tim

With that avatar I should drive up and help ya. GO IRISH!

87MCProstar
06-05-2008, 07:19 AM
Chief, I've bleed blue and gold for as long as i can remember.