PDA

View Full Version : cuts out on WOT


robin
05-21-2008, 12:48 AM
just had by boat out over the weekend. runs like a champ, other then on wide open. it starts cutting out. as soon as i back if off a hair, it starts running fine again. ive been reading other threads and it sounds like i should replace the fuel filters and check in the tank for debri.
my boat: 1999 sportstar 19, with vortec 350 tbi. the fuel pump is a pull style/in line, on the engine, not in the tank. does this set up have a screen on the fuel pickup in the tank? any other ideas? itching to get back up and troubleshoot! thanks!

jimmer2880
05-22-2008, 05:48 PM
just had by boat out over the weekend. runs like a champ, other then on wide open. it starts cutting out. as soon as i back if off a hair, it starts running fine again. ive been reading other threads and it sounds like i should replace the fuel filters and check in the tank for debri.
my boat: 1999 sportstar 19, with vortec 350 tbi. the fuel pump is a pull style/in line, on the engine, not in the tank. does this set up have a screen on the fuel pickup in the tank? any other ideas? itching to get back up and troubleshoot! thanks!

I don't believe there is a screen in the tank. However, there is a screen where the fuel-line enters your fuel pump. The screen is between the screw-in compression fitting an your pump. That's where mine always clogged.

erkoehler
05-22-2008, 06:31 PM
Where are you at in the midwest?

robin
05-27-2008, 10:00 AM
from indiana....
just got back from working on it....appears to be the prop i just had rebuilt....letting it over rev and and the rev limiter is cutting it out....works fine with my extra prop....