PDA

View Full Version : Speedo help????????????????


ShamrockIV
04-28-2008, 09:46 AM
hey ya'll
can u guys help me please. my 209 has PP. The remaining speedo goes all the way to 50 when u put the engine in gear!! when u go back to neutral or reverse it drops. any ideas or suggestions would be greatly appreciated!!!

defender1009
04-28-2008, 09:58 AM
hey ya'll
can u guys help me please. my 209 has PP. The remaining speedo goes all the way to 50 when u put the engine in gear!! when u go back to neutral or reverse it drops. any ideas or suggestions would be greatly appreciated!!!

Man, sounds like you need to seriously reduce your idle speed! :D

(Sorry, I'm not much help---just had to share what popped into my head).

ShamrockIV
04-28-2008, 10:01 AM
Man, sounds like you need to seriously reduce your idle speed! :D

(Sorry, I'm not much help---just had to share what popped into my head).


thanks for your help!!!
u SC folks seem really smart!!!!! :rolleyes:

#47of100TeamMC
04-28-2008, 10:10 AM
I was nervous to open this thread... it just didn't seem right that a grown man would ask for help with his speedo. I was relieved to see which speedo you are talking about.

Sorry I can't help though...

ShamrockIV
04-28-2008, 11:32 AM
can a man just get some help here????

oh well if no help here maybe someone at csm can help!!

TMCNo1
04-28-2008, 07:53 PM
Go from a red to yellow speedo and the problem will decrease!

VOLFAN
04-28-2008, 08:18 PM
I think his is probably camo if I was guessing.