PDA

View Full Version : Ballast guage problem


badams
04-23-2008, 03:56 PM
I have a 2006 X2. When I drain the ballast tanks the guages still read that all three tanks are half full. Does anyone know how to get my ballast guages to read correctly?

kevfischer
04-23-2008, 04:27 PM
I had an an 06 X2 and had this problem from day one. I got them reset at the dealer and they worked for a couple trips. I now have an 06 XStar and they don't work correctly but I also have the additional fly high system. Have your dealer recalibrate them and hopefully they will work correctly.

endl
04-23-2008, 05:01 PM
I had to have my 06 guages recalibrated as well. Seems like they pull them out and adjust them from the rear of the guage.

Jerseydave
04-23-2008, 07:27 PM
On my '05 X-star I adjusted the ballast tank sending units which are located at the top of each tank. They are VERY sensitive when it comes to adjusting them. (slight turn of the screw) I still haven't got the KGB one set right. I did it with the boat in the water, adjusted with tanks full and empty.

Chief
04-23-2008, 07:34 PM
I have a 2006 X2. When I drain the ballast tanks the guages still read that all three tanks are half full. Does anyone know how to get my ballast guages to read correctly?

Make sure you run the boat at a slow speed to get the bow up. Mine read 1/2 full because they were. Now I get the bow up and make sure all the water gets out. They read empty now.

You can also adjust the pots on the top to read empty also if the tanks are drained.

Deron Crook
07-19-2010, 06:50 PM
Having the same problem with the quages. What do you mean by adjusting the pots?

bturner2
07-20-2010, 09:11 AM
Same as everyone else here. Mine don't read correctly and need to be adjusted. The strange part is after they drain they'll be between 1/4 and 1/2. The next day their at 1/8 to 1/4. They rarely ever work right. A lot like fuel gauges in my opinion. They give you a general idea of where the level is but I sure wouldn't trust them.

ttu
07-20-2010, 09:14 AM
mine worked the 1st few times i took the boat out and since then they read all over the place. one of the reasons i wish in 07 and newer models drained out the side instead of under the hull so you could tell when they are empty.

snork
07-20-2010, 10:50 AM
Remove the small access cover approx 4" and black normally under the seats above the tanks. One for each tank .
When the cover is removed you'll see the water level sending unit with two adjusting screws with a + and - marked next to each screw. Make very small adjustments to each screw. I do believe + is for the full level and - for empty level. As njskier stated they are sensitive and make small adjustments.