PDA

View Full Version : on board computer


redx10
03-23-2008, 04:37 PM
:confused: Does anyone know about how much a new 350mcx LS1 computer costs? My boat all of a sudden will not start, the gas guage quit and the fuel pump will not come on. I unpluged the fuel pump and ran 12volts directly to the pump and it works, I checked the relays and they are all good. Are there any fuses for the fuel pump? I'm thinking the computer has gone out???

03 35th Anniversary
03-23-2008, 04:51 PM
Try your emergence shut off switch. Make sure its working right first.

dmayer84
03-23-2008, 05:02 PM
Check the circuit breaker right near the battery

vision
03-23-2008, 05:35 PM
As 03 35th Anniv indicated, it is the the kill switch until proven otherwise. They can be touchy. Make sure the switch is depressed all the way.

JohnnyB
03-23-2008, 05:55 PM
:confused: Does anyone know about how much a new 350mcx LS1 computer costs? My boat all of a sudden will not start, the gas guage quit and the fuel pump will not come on. I unpluged the fuel pump and ran 12volts directly to the pump and it works, I checked the relays and they are all good. Are there any fuses for the fuel pump? I'm thinking the computer has gone out???

Symptoms sound very much like the kill switch!

JohnnyB
03-23-2008, 06:01 PM
OK....little thread-jack...where do you buy a spare clip that attaches the lanyard to the switch. The clip on mine seems to be a bit deformed and doesn't hold the button in all the way.....mine has a single wrap of athletic tape around the "finger" on the clip that holds the button down.

TMCNo1
03-23-2008, 06:12 PM
You may have to buy the whole unit and if the clip works on yours, save the switch in case you need it later, or even replace the whole thing now, http://www.skidim.com/prodinfo.asp?number=SIEMP40970

D3skier
03-23-2008, 06:48 PM
even try putting a jumper on the switch this way you eliminate that all together of being the culprit... I had to replace my ECM just last year on my old boat and it cost me around $1200

redx10
03-24-2008, 11:32 AM
Hey guys, thanks sooooooooo much for the replys, the kill switch clip wasn't holding the button down all the way. 2 wraps of tape=$0.00

TMCNo1
03-24-2008, 11:35 AM
Wow, another kill switch problem bites the dust. Great to hear it was that simple!

drballenbc
05-11-2014, 05:36 PM
Ty to op. Saved some time finding this thread. Same solution. Tape.


Sent from my iPhone using Tapatalk

JimN
05-11-2014, 06:42 PM
OK....little thread-jack...where do you buy a spare clip that attaches the lanyard to the switch. The clip on mine seems to be a bit deformed and doesn't hold the button in all the way.....mine has a single wrap of athletic tape around the "finger" on the clip that holds the button down.

West Marine, Fleet Farm, Menards may have them.