PDA

View Full Version : Missing bolt, front of h2o supply pump, size?


bridomine99
03-22-2008, 11:18 AM
I noticed one of the four small bolts (they look like they are brass) on the front of the cover for the water supply pump is missing. My engine is a LTR. Does anyone know the thread and lg of this bolt so I can get a replacement?

Thanks

JLeuck64
03-22-2008, 12:36 PM
Take another one of the bolts out and go visit a hardware store. They should be able to fix you up.

bigmac
03-22-2008, 12:47 PM
http://www.skidim.com/prodinfo.asp?number=68-5005

http://www.skidim.com/images/68-5005.jpg

coz
03-22-2008, 12:51 PM
I noticed one of the four small bolts (they look like they are brass) on the front of the cover for the water supply pump is missing. My engine is a LTR. Does anyone know the thread and lg of this bolt so I can get a replacement?

Thanks

One of these?
http://farm4.static.flickr.com/3062/2347896762_542f844c7f_b.jpg

Here's what TMC1 did.
I agree, but on mine I replaced the screws with S/S allen head screws and S/S washers and I don't have the tendency to tighten them too much that way when just using a allen wrench. Always use a new gasket each time you take off the cover!

Footin
03-22-2008, 01:24 PM
I replaced mine with allen head bolts an lock washers, they are stronger and much harder to strip.

bigmac
03-22-2008, 01:28 PM
I replaced mine with allen head bolts an lock washers, they are stronger and much harder to strip.


But easier to strip the brass pump body?

That potential problem not withstanding, as well as the dissimilar-metal problem (Nev R' Seeze is great stuff), I really like the idea of replacing those bolts with hex-head cap screws. My solution was to have a bunch of extra brass bolts from SkiDim sitting around, but I certainly see the advantage of Harold's and Footin's solution.

bridomine99
03-23-2008, 09:49 AM
http://www.skidim.com/prodinfo.asp?number=68-5005

http://www.skidim.com/images/68-5005.jpg

Thanks guys, I'll order a few from bigmac.