PDA

View Full Version : Check engine light 1999 230 VRS 5.7 Vortec


Bruce
02-26-2008, 06:36 PM
As some of you may remember I have been trying for months to get an answer as to why my check engine light does not come on when I turn the ignition switch to the on position. I got lots of replies but alas, most were wrong. Some I believe it was JimN remembered that there was a service bulletin about it. I believe it was Mike who mentioned miswiring problem on some 1999's. Etc. etc. I tried local dealer no luck. At JimN's recommendation I called Gregg Clower at MC. They could not find anything and he suggested I contact an old timer at Rambo Marine(can't remember his name) that had been around long enough that he might recall the situation. He was out sick so I got James who bent over backwards to help after lots of searching he could not find service bulletin tin his archives. However, in going over this he recalled that in the 1999's the light did not come on at all unless there was a problem and a code was sent to the ECM. (He also mentioned something about a MDC or MMDC box). So there you have it. Many thanks to all who helped. (Now if one of you has this same boat and engine and your light comes on-------well!!)

flipper
02-26-2008, 07:09 PM
Couldn't you check this theory by unplugging a sensor or something that would trigger the light to see if it comes on? Just a thought so you know it works.

Bruce
02-26-2008, 07:16 PM
Couldn't you check this theory by unplugging a sensor or something that would trigger the light to see if it comes on? Just a thought so you know it works.
I could unplug knock sensor and it should. However, that still did not answer question as to should it come on with ignition on as in most other boats, cars etc.

coz
02-26-2008, 07:30 PM
As some of you may remember I have been trying for months to get an answer as to why my check engine light does not come on when I turn the ignition switch to the on position. I got lots of replies but alas, most were wrong. Some I believe it was JimN remembered that there was a service bulletin about it. I believe it was Mike who mentioned miswiring problem on some 1999's. Etc. etc. I tried local dealer no luck. At JimN's recommendation I called Gregg Clower at MC. They could not find anything and he suggested I contact an old timer at Rambo Marine(can't remember his name) that had been around long enough that he might recall the situation. He was out sick so I got James who bent over backwards to help after lots of searching he could not find service bulletin tin his archives. However, in going over this he recalled that in the 1999's the light did not come on at all unless there was a problem and a code was sent to the ECM. (He also mentioned something about a MDC or MMDC box). So there you have it. Many thanks to all who helped. (Now if one of you has this same boat and engine and your light comes on-------well!!)

I have that engine in my 205 and my manual says it will go on only when there is a problem. To bad I didn't see this post, I might have saved you some frustration. :D