PDA

View Full Version : Loses RPM after several minutes above 3000 RPM / Loses Power above 3000 RPM


deonsap
02-14-2008, 07:31 AM
Hi team. I am a new guy. I am excited and feel privileged to join this community. I have a 1996 Mastercraft MariStar 225VRS with an Italy Hurth Marine MastercrafPower EFI engine.

My problem:

Can pull forever below 3000 rpms, no problem. Cruising at 4500 rpms, after a while, 15 minutes or so (sometimes only 5 minutes at full throttle) the rpm start to slowly drop right down. Put the engine in neutral for a minute, and back to normal. However, tapping back on the throttle when the problem starts will allow it to level out at about 3000 RPM. Think it is a fuel pressure problem. The fuel line configuration is: 1) Fuel tank; 2) Fuel filter A; 3) Fuel pump; 4) Fuel filter B; 5) Fuel injectors, 6) Regulator 7) back to Fuel tank

What we’ve done so far:

1. Checked all the team talk threads, but none of them have a conclusive solution given our investigation below.
2. No faults found when running a diagnostics at the time of the problem (although there is an outside temperature sensor failure, but this problem existed before the RPM power loss problem)
3. Bypassed fuel filter A – still have the problem
4. Pressure tested the fuel pump, fuel filter B and the regulator on a test bench - ran it for over 20min – pressure is constant and within spec – will still have the problem

Request:

If you have experienced the same problem or have any good suggestions please let us know. We are planning to run some tests this week-end and would appreciate suggestions.

Thank you,
deonsap

deonsap
02-14-2008, 07:53 AM
Sorry guys. I realized I should have posted this tread under the Maintenance / Engine / category. I will repost it there.