PDA

View Full Version : 89 Prostar 190 alternator


hydro-therapy
10-22-2007, 01:37 PM
Have a 89 190 w/1900 hrs alternator haas been rebuilt a couple of times and just isn't puttin out enough voltage to run all the stuff. Stereo, heater, bilge, navs ect... any reccomendations for a new higher output alternator? BTW its an Indmar engine.

TMCNo1
10-22-2007, 02:28 PM
Your MC dealer, a MC dealer or www.skidim.com (http://www.skidim.com), http://www.skidim.com/products.asp?dept=1030&pagenumber=2&sort_on=&sort_by=

88 PS190
10-22-2007, 07:27 PM
wow, my boat doesn't have any of that extra stuff in it... who needs music in a boat... you have the brrrrrrrrmmmm noise

learjet2230
02-13-2008, 06:30 PM
wow, my boat doesn't have any of that extra stuff in it... who needs music in a boat... you have the brrrrrrrrmmmm noise
Am I reading this right. Are you the same guy that gave me all the la la about noise coming from boats in the straight pipe thread!!??

flipper
02-13-2008, 06:52 PM
Am I reading this right. Are you the same guy that gave me all the la la about noise coming from boats in the straight pipe thread!!??

:purplaugh

sk8salomon
02-14-2008, 08:27 PM
i had the same problem with my 89. when i turned on multiple things like radio, lights, bilge, etc. the voltage meter would drop to like 8~9 volts. i thought right away it must be the alternator crapping out. i took the alt to a shop and found it was putting out the recommended 60A. guy said, "sure its not your battery?" my battery was only 3 years old so i took it to a shop and had it tested. not just quick tested, but put it thru a 30 minute cycle test. the test puts the battery thru all sorts of load tests, short term & long term. turned out it had a bad cell and couldn't hold a charge during large loads. otherwise, the battery was fine, started fine, lights work, etc. put a new battery in and fixed the problem immediately.