PDA

View Full Version : Overriding Timing on 2008 Ballast Pumps


teamstreng
10-02-2007, 01:29 PM
We took delivery on our 08 X-2 and are very pleased. However, I have begun to install the X-2 sacs in the rear and integrated bow sac in the nose and the stock pumps stop running too soon to fill the extra tanks. Then there is a problem emptying completely due to the time.

Has anyone overcome this?

What is the solution?

Thanks.

Fitz2333
10-02-2007, 01:40 PM
Can you post a few pictures of your install - and any lessons learned - I too have the 2008 X-2 and just received the integrated ballast system from BFI/FATSAC - Thanks in advance!

Roonie's
10-02-2007, 01:50 PM
I too am going to install more ballast integrated. The dealer told me the fix but I have since forgotten it. I remember reprogramming for longer times on the ballast pumps or something of that nature. I was going to ask again when the time came to install system.

duckguy
10-02-2007, 01:53 PM
Yup they reprogram the ballast pumps for more time. in 07 six minutes was as long as it could go. 08 goes up to 20 minutes. Your dealer can do this process in 15 minutes.

duckguy
10-19-2007, 05:09 PM
I dont know how to do it

Ole Miss Rebels
10-19-2007, 06:00 PM
Yup they reprogram the ballast pumps for more time. in 07 six minutes was as long as it could go. 08 goes up to 20 minutes. Your dealer can do this process in 15 minutes.


i was told that the older 08 models don't yet have the three (3) new black boxes that allow for programming up to 20 minutes. the newer black boxes will be installed as a running change sometime soon. if your boat has the "old style-2007 year model) black boxes you will have to upgrade the black boxes when they become available to your dealer. i was told approx. $100/box.

1boarder
10-20-2007, 12:22 PM
Are the fly high systems worth it? Can you just buy the bags and tie into the vent of the hard tanks for half the price or do the 3 way valves actually add functuality?

duckguy
10-20-2007, 01:00 PM
I would go the half the price route

1boarder
10-20-2007, 03:42 PM
Here is how the 07s were adjusted. They had a 6 min max. I got this off of the web and I never have tried it but I assume it works.

Step 1.
Disconnect the Ballast Control Box (port rear comparment X2) from the battery.

Step 2.
Re-connect the Ballast Control Box to the battery. You NOW have only 30 seconds to do the following.

Step 3.
Select: FILL OFF FILL to get into programming mode.
Then each time you select FILL you add 5 seconds of FILL time
Each time you select EMTY you subtract fill time.

Step 4.
Return switch to off position then leave it alone for a few minutes. Then put in the water and try it!



Could some of you guys who have put in the fly high system (or at least the bags) post some pics or how you designed the system and what you think about it?

wpstevenson
10-23-2007, 06:49 PM
Just took delivery of my 2008 X2. Looks like the relay control modules still have the 6 min max then wrap around to 15 sec. Was told we could get new modules that can go to 12 Min max. ????? My pumps ran for 4 min when filling from the factory, filled tanks in about 3 min shot out overflow until they timed out at 4 min. They only ran for 2.5 mins on empty before timing out, back tanks seemed empty but had to hit switch on 3more times at 15 sec a shot to get the center tank empty. Tryed to reprogram but could not get them into program mode. I'll try again this weekend.

How are you connecting the additional bags. On my 2007 x2 I teed into the fill/empty line and ran it to the bag. That worked ok, but really didn't get the bag completly full before starting come out the over flow. Same on emptying, never did get the bag completly empty before sucking air through the tank.