PDA

View Full Version : All gauges go out...........


MC2000190
09-13-2007, 04:53 PM
Can anyone tell me why all my gauges go out randomly then after a restart will be working again?

Monte
09-13-2007, 09:50 PM
Can anyone tell me why all my gauges go out randomly then after a restart will be working again?

Short....................

Tom023
09-14-2007, 03:44 PM
Either bad MDC box or gauges themselves could be two possible reasons. Search the forums for "MDC" and you may find discussions related to this topic if they are still available.

dsoby
09-14-2007, 03:48 PM
My oil pressure and (not so often) voltmeter have done since the boat was new. The MDC was replaced twice in the first year. The official explanation is that this is a grounding issue and the fix is to run separate ground wires from the affected guages but I haven't bothered with it yet. This, supposedly is a common problem.

Tom023
09-14-2007, 05:28 PM
The MDC replacement didn't solve the problem for me either, helped, but not a complete fix. I have an extra gauge connector under the dash from speedo, when the PP took that spot. So, I got the dealer to start giving me gauges and I would hook up one under the dash...when the one in the dash would fail, I would check the one under to see if it failed too. Every single time, it was only the gauge in the dash that failed. I wound up replacing all, at MC's expense, and never have had a problem since. The replacement gauges have a sticker on them that say "Rev B", so maybe there was a design change.

ProTour X9
09-14-2007, 05:31 PM
Theres something we did that fixed the problem and it only came back once in 3 months