PDA

View Full Version : 2007 X-2 performance?? low top speed


gspliff
08-29-2007, 08:36 PM
I have a stock engine/factory prop 2007 x-2. it has really good pulling power but two major concerns are:
top speed of 29???????? this is on perfect pass and analog. I owned a stock 2001 x-star till this summer and it would pull just as well but topped out at 48 miles per hour.

I also find that is does not perform 180's nearly as good as my old x-star.

I am obviuosly a mastercraft fan, and I LOVE all of the features of my x-2, im just trying to get performance comparison's from other owners. thanks.

Chicago190
08-29-2007, 08:52 PM
Yeah thats way low. What RPM are you turning at that speed? Engine and altitude you are at?

Roonie's
08-29-2007, 09:14 PM
I sent you a PM stating basically the same thing.

I am getting top speed of 46-47 at 5100 RPM. Something is wrong if your only getting top speed of 29. I have the edge XMP 14.25 x 14.5 prop which I highly recommend if you don't have it yet. OJ props carries them. Hands down the best prop out there for the X2 and most 07 now come with that prop. I would highly recommend either going to your dealer and asking about your top speed or it could be your speedo is not calibrated correctly and so it is showing wrong speed. They are easy to calibrate and show how in your owners manual. If you have a hand held GPS it should be no problem. If it is correct then something is wrong.

edit.... I see you mentioned perfect pass is showing same thing so maybe something else is wrong and I would recommend asking dealer about it as your top speed is not right.

Willytown
08-29-2007, 10:46 PM
something is not right. what rpm's are you running at? You should be able to hit mid 40's with ease. Stupid question, but are you sure your pp isnt catching at 29? I would check with your dealer given that its an 07 and you probably havent had it that long

Willytown
08-29-2007, 10:46 PM
something is not right. what rpm's are you running at? You should be able to hit mid 40's with ease. Stupid question, but are you sure your pp isnt catching at 29? I would check with your dealer given that its an 07 and you probably havent had it that long

erkoehler
08-29-2007, 10:50 PM
Take it immediately to your dealer, you don't want to mess with anything.

It is under warranty, MC will fix it.