PDA

View Full Version : Trailer connector intermittent


Leroy
08-24-2007, 08:34 PM
The connector to my trailer is intermittent and only works if I jam it together and wrap a rubber band around the two connectors.

Anyone know of solutions short of replacing the connectors?

TMCNo1
08-24-2007, 08:48 PM
The connector to my trailer is intermittent and only works if I jam it together and wrap a rubber band around the two connectors.

Anyone know of solutions short of replacing the connectors?
Try a little WD-40 on all the connector joints and maybe gently squeeze the female holes with a pair of pliers to tighten everything up.

Leroy
08-24-2007, 09:08 PM
Thanks Harold, I'll try that. I could not find anything on here before or searching Google.

ski_king
08-24-2007, 09:26 PM
The connector to my trailer is intermittent and only works if I jam it together and wrap a rubber band around the two connectors.

Anyone know of solutions short of replacing the connectors?
Do you know a good electrical engineer that can take a look at it?

Just kidding. Harolds suggestion of WD40 has worked many times for me.

Also Duck Tape works better than rubber bands..

Leroy
08-24-2007, 09:36 PM
Oh, I can look at it and that would be about it! ;)

I'm sure my techs could fix it! :D

I am using the Lance Armstrong rubber bands, much better than duck tape!

Do you know a good electrical engineer that can take a look at it?

MarkP
08-24-2007, 09:45 PM
Unfortunately, if Harold’s suggestion doesn’t work well or for long your probably better off just replacing the connector.. It shouldn’t be expensive at all (at a trailer shop), as it is not that involved..