PDA

View Full Version : '93 Corvette owners, a little help (repost from General Discussion forum)


ride
08-16-2007, 04:57 PM
I need to find a part number for the ECM/MEFI computer that is mounted on the rear of the engine, but only a '93 number will do. This is the number on the bottom/back of the computer itself and is hidden againt the mounting plate. Its the number with the word "MODEL" listed right beneath it. If anyone knows theirs off hand, that would help me out a ton. I'm in need of finding/buying one to swap mine out. I guess the '93 can be reprogrammed to higher altitudes better than mine.
I appreciate any help you can give me but in case anybody goes to the extent of pulling theirs off to look up that number for me (thanks in advance), BE SURE to diconnect the negative battery cable BEFORE doing so.
Again, thanks in advance.

ride
08-16-2007, 05:01 PM
I need to find a part number for the ECM/MEFI computer that is mounted on the rear of the engine, but only a '93 number will do. This is the number on the bottom/back of the computer itself and is hidden againt the mounting plate. Its the number with the word "MODEL" listed right beneath it. If anyone knows theirs off hand, that would help me out a ton. I'm in need of finding/buying one to swap mine out. I guess the '93 can be reprogrammed to higher altitudes better than mine.
I appreciate any help you can give me but in case anybody goes to the extent of pulling theirs off to look up that number for me (thanks in advance), BE SURE to diconnect the negative battery cable BEFORE doing so.
Again, thanks in advance.

Jim@BAWS
08-16-2007, 05:03 PM
appreciate any help you can give me but in case anybody goes to the extent of pulling theirs off to look up that number for me (thanks in advance), BE SURE to diconnect the negative battery cable BEFORE doing so.



Sounds like a job for the owner

Monte
08-16-2007, 05:10 PM
Have you called any salvage yards yet?

André
08-16-2007, 05:29 PM
I would try the Corvette forum Mag used to be on...:)

Mag_Red
08-16-2007, 05:42 PM
I would try the Corvette forum Mag used to be on...:)I was going to recomend that site Andre.....great parts section! Corvetteforum.com...........tell em Mag Red Monster sent ya ;)

André
08-16-2007, 05:50 PM
...tell em Mag Red Monster sent ya ;)
Don't !!!
Or you'll become a chick magnet!!!

JimN
08-16-2007, 06:04 PM
That's not the same ECM as what was used in the cars, though AFAIK.

Mag_Red
08-16-2007, 06:12 PM
Don't !!!
Or you'll become a chick magnet!!!:purplaugh

Upper Michigan Prostar190
08-16-2007, 08:19 PM
I would try the Corvette forum Mag used to be on...:)
Yea, what he said. I dont think there are 93 Corvette owners on here. Maybe 5 or 6 of them, but certainly not 93 of them.

roddydog
08-16-2007, 08:37 PM
'vette owner:( What else need be said:o ???



Other than..................WRONG FORUM!!!!!!!!!!!!!!!

ride
08-17-2007, 01:56 PM
All right, all right. I guess I'm learning what sort of trouble you can get into if you log out....

I'll try MAG's suggestion, but JimN is right. My understanding from Indmar's Tech. Services is that it's a different (and specific) part. Something about the whole marinized version that's gel-packed and sealed, etc, etc. AND apperently my best option is to find the one that was specifically placed on the '93.

I do like the chick magnet idea, tho...

Monte
08-17-2007, 02:07 PM
I thought you were talking about a Corvette (the car) not the LT-1 engine (for a boat).....

ride
08-17-2007, 02:11 PM
'vette owner:( What else need be said:o ???



Other than..................WRONG FORUM!!!!!!!!!!!!!!!

So, I gotta disagree on this one. Appologies if I'm clogging up the forum with the question, but I figure if there's a '93 vette owner that's skilled enough to undo their batt. cable, loosen the four bolts holding their ECM on to check the p/n for me, its definitly on THIS forum... mabey Electrical also. From what I've observed, only the best and the brightest have any interest in frequenting this forum, a huge asset to for those of us that want/need to learn more about their boat.:)

ride
08-17-2007, 02:13 PM
I thought you were talking about a Corvette (the car) not the LT-1 engine (for a boat).....

I see your point. Sorry, sorry. Should have been more specific.... In my defense tho, my original post specified the LT-1... The double-thread I believe came from the moderator kicking my double post out of the General Discussions forum.