PDA

View Full Version : 1991 prostar problem


bms447x
08-01-2007, 10:34 PM
bought a 91 prostar last year, one owner with 323 hours on it. tried it out for 2 days, ran fine wide open, until went to load on last day. problem when going to ramp gave it one last w/o run and it would die(bogg) when full throttle, but when let back on gas would re gain speed, thought just change spark plugs, little to say bought the boat. changed plugs ran fine at 30-38mph but if got any faster it would start to bogg about 8-10 seconds after w/o. just delt with it all last year. start of this season, changed plugs went to lake, still with same idea, been fine last 4 or 5 weeks, still not ever going w/o, same30-38mph, last week started to bogg at 26-31mph, need help, very mech inclined, is this a problem fuel wise, timming, rotor button, carb, i need help

mayo93prostar
08-01-2007, 10:38 PM
could be fuel pump, fuel filter, fuel filter on fuel line input to carb, screen in fuel pickup in tank, antisiphon valve on top of tank. check and clean and/or change these. my suggestions.

JohnnyB
08-01-2007, 10:42 PM
IIRC, there are others that have had a hot-running issue like you have described....I'll do some searches and see what I can come up with. The search function on this site is great.

Things to check/change in the fuel system:

1) in-line fuel/water separator filter
2) Fuel pump filter
3) Strainer screen between the fuel pump and the carberator (see the manual, downloadable from this site)

While you're at it:

1) change PCV Valve
2) check timing of engine
3) clean the flame arrestor