PDA

View Full Version : LT-1 Overheated


alpine740
07-16-2007, 08:00 PM
Ran the boat through some floating debris, plugged up the trans cooler and overheated the engine up to 240 degrees before my ski partner noticed the temperature. Boat only ran hot for a few minutes at 9 mph (we were wake surfing).

Any thoughts on how much damage may have been incurred?

I let the boat cool down to 180 degrees before restarting and it seemed to run fine (no apparent short term damage). No obvious burned exhaust hoses or cracked exhaust manifold. I am most concerned about potentially cracked heads or a bad head gasket getting progressively worse. Looking for input from others that have run an engine up to this temperature. Thanks in advance for any input.

don937
07-17-2007, 11:07 AM
I've had my LT1 that hot with no apparant damage. Just for safe measure, I did a compression test on all cylinders and they all looked to be good.

Thrall
07-17-2007, 03:32 PM
I haven't personally experienced a bad overheat w/ my LT1, but have overheated a couple times due to plugged intake.
From what I've been told/read, your exhaust hoses would probably be the first thing to go if it overheated badly (rubber melts before aluminum). If hoses are ok and boat runs fine, I think you're alright.

alpine740
07-17-2007, 09:05 PM
Thanks for the feedback guys. I plan to pull the plugs this weekend and see if they still look normal. I ordered a strainer, fittings, hose section and 2 day shipping from skidim.com for less than $100. Cheap insurance going forward.