PDA

View Full Version : engine cutting out


ttu
07-16-2007, 10:25 AM
325 hd indmar efi engine. boat starts and runs fine, but when you go to put the thottle all the way down (3200 rpm's) it cuts in and out.

wondering if there is water in the fuel because over the 4th holiday i filled up twice at the marina in the lake.

any ideas. (because boat is sold pending delivery) and it's time to get my new x2.

ttu
07-16-2007, 12:51 PM
come on guys, no help.

PendO
07-16-2007, 01:38 PM
efi or carb? (OKAY, i see where you said efi)

If you think its bad gas siphon it into your car and see how it runs:)

PendO
07-16-2007, 01:41 PM
I'd siphon out the gas into cans and take it to the dump (usually you can take it in 5 gallon pails) ... also, I would replace the spark plugs, and for good measure I would check the fuel pressure when you have it running ...

dmayer84
07-16-2007, 01:43 PM
if you think there is water in the gas why not try some dry gas

ttu
07-16-2007, 01:46 PM
if you think there is water in the gas why not try some dry gas

when i was up test driving the x2 yesterday i picked up a inline filter and some heet.

suppose to meet with the mechanic this afternoon (buyer want a compression check) and we check it out.

just hoping to have some more info.

KBryant2007
07-16-2007, 11:45 PM
Had the same thing happen on my MCX 350. Ended up replacing the fuel line filter and fuel pump. That solved my problem, although at first it seemed like bad gas just as you've mentioned.

ttu
07-17-2007, 08:02 PM
well turned out to be the filter. took it out today after the mechanic installed a inline filter and it ran great.

thanks for all your help..

ps, she is sold.

hoping to pu the new x2 saturday.

saying goodbye to the current one on thursday...