PDA

View Full Version : Removing Bilge pump


BradD
07-02-2007, 09:26 AM
I have a 1992 ProSport with a bilge that runs but does not pump out water. I'm hoping to simply clean it out, but wanted to check with you all on how the pump comes out. The lighting was bad so i could not see if there were screws holding it in place or if it is a snap fit.

The reason having a functioning bilge is important is because i seem to be taking on an excessive amount of water. I have to put the boat back on the lift every hour to drain the boat.

BradD
07-02-2007, 12:04 PM
anyone have some suggestions?

dpolen
07-02-2007, 02:54 PM
Most bilge pumps just snap into place...there is a base that get's glued to the bottom of the bilge and the motor snaps right into the base. It's a pretty easy project. Hope that helps a bit.

cwright
07-03-2007, 12:46 PM
I ran into this last year, and received a suggestion on this board to rotate it in its base. And what do you know, rotated it 90 degrees and it came right out. If you can't see any mounting screws in the base, I suspect you have the two piece type that twist onto a base. Good luck

cbryan70
07-03-2007, 12:53 PM
if you can hear the bilge maybe the hose leading out is just clogged. This happend to my boat and i just took a hose and stuck it into the exit of the bilge water and washed the hose out. There was a bee's next in the bilge from storage that got flushed out and it worked again. Maybe try that?

BradD
07-05-2007, 10:44 AM
The motor ran, but the impeller would not turn. Installed new pump yesterday and it worked wonderfully.
Now i need to determine why i'm taking in so much water!!

softailcowboy
07-07-2007, 03:00 PM
I would check the output shaft. It should drip a little but may be out of adjustment