PDA

View Full Version : 2003 x7 Speedometer Broken


jwroblew
06-17-2007, 12:00 PM
I have a 2003 X7 with the left speedometer broken., the one on the perfect pass works fine. Do both speedo's work off of the padel wheel? Where should I start to look to solve the problem :confused:

Ric
06-17-2007, 12:03 PM
I would say that the MC speedo does not run off the paddlewheel in 2003, but you can confirm by looking to see if your boat has pitot tubes on the transom

Bob B
06-17-2007, 01:44 PM
See my post 2002 Prostar190.

My MC speedo still broke.
http://www.tmcowners.com/teamtalk/showthread.php?t=10894

Bob B

bigmac
06-17-2007, 02:10 PM
I have a 2003 X7 with the left speedometer broken., the one on the perfect pass works fine. Do both speedo's work off of the padel wheel? Where should I start to look to solve the problem :confused:

I believe that 2002-and-later MasterCrafts used digital instrumentation and that all speedo information came from the paddlewheel. MC even supplied a plug-and-play harness specifically for Perfect Pass (according to the Perfect Pass install (http://perfectpass.com/download/usersmanuals/UserManual.WakeboardProGraphics6.5.2005_older.pdf) manual) that connected the PP Master Module unit directly to the the OEM paddlewheel. If the OEM speedometer was left in place and connected to the MC instrument computer, the user would get speedo info on both the PP display and the OEM speedo. If you're getting speed info on the PP display but not on the OEM gauge then the problem would likely be with the OEM speedo gauge head, the wiring going to it, or the MC instrument computer. If all your other gauges are working OK, then problems with the MC MMU are less likely and I'd focus on the wiring first, then the gauge itself.

Anyway, that's how I see it based on my experience with installing Perfect Pass on my 2004 (and PP says 2002 is same setup as 2004). I had to remove my OEM speedo and disconnect its plug in order to have someplace to put the PP display.