PDA

View Full Version : Engine Problems, could it be the Ethanol?


markfromtexas
06-06-2007, 03:40 PM
Hey guys, it's been awhile since I've posted, but I knew this would be the place to find the answer.

04 X-30, just over 200hrs. This last weekend, I was out for about 6hrs or so and after being on the water for awhile, my engine would die while idling and then have problems starting back up. When I'd try to restart it would either not try a bit or would fire up, run rough, and then die. It did this several times, but would run fine after letting it sit for about 5-10min.

Any suggestions?

My boat guy says the ethanol could be playing a part in the matter but since I don't know where to go to get non-ethanol gas, I'm SOL!

Thanks

Andyg
06-06-2007, 03:53 PM
As long as you are using only 10% ethanol you should have no problems. I would suspect you have another problem. What engine do you have? Is your engine light on you dash coming on at all? Have you cleaned your flame arrestor recently? When was the last time you changed the spark plugs? Are all of your plug wires seated properly on the spark plugs. Most likely it isn't any of the above it if came on all of a sudden and didn't notice any performance problems leading to this.

On my 97 190 with the LT1 I had a similar problem. While it is a different engine the basic principles are the same. I had a bad IAC. Once that was replaced it idled great again.

markfromtexas
06-08-2007, 06:13 PM
Andy,

I've got the MCX engine and it sounds alot like the others that have posted in the last couple days...No unusual lights showing.Haven't cleaned flame arrestor but will give it a shot. It turns over real strong, but acts as though it's not getting any gas for the combustion. I'll pull the plugs and see what I can find.

Thanks for the suggestions.

bigmac
06-08-2007, 06:22 PM
Hey guys, it's been awhile since I've posted, but I knew this would be the place to find the answer.

04 X-30, just over 200hrs. This last weekend, I was out for about 6hrs or so and after being on the water for awhile, my engine would die while idling and then have problems starting back up. When I'd try to restart it would either not try a bit or would fire up, run rough, and then die. It did this several times, but would run fine after letting it sit for about 5-10min.

Any suggestions?

My boat guy says the ethanol could be playing a part in the matter but since I don't know where to go to get non-ethanol gas, I'm SOL!

Thanks

Sounds exactly like my boat's performance as the fuel pump was dying.

markfromtexas
06-21-2007, 06:18 PM
Thanks for the suggestion, I'll keep my eyes on that fuel pump...

Take care,