PDA

View Full Version : Perfect pass is dead?????


TX.X-30 fan
06-03-2007, 09:43 PM
The perfect pass took a crap this weekend. Warning buzzer was going off and the display had black bars half way across the screen. It was probably 10 min later the unit went dead completely. The water was a little choppy and I hope its just a connection somewhere but everything was so hot back there I didn't look much. I left the boat at TSR in New Braunfels. Just wanted to sound intelligent when I talk to the service guy tomorrow. I know very little about these units. Any help would be appreciated. ;)

milkmania
06-03-2007, 10:27 PM
The perfect pass took a crap this weekend. Warning buzzer was going off and the display had black bars half way across the screen. It was probably 10 min later the unit went dead completely. The water was a little choppy and I hope its just a connection somewhere but everything was so hot back there I didn't look much. I left the boat at TSR in New Braunfels. Just wanted to sound intelligent when I talk to the service guy tomorrow. I know very little about these units. Any help would be appreciated. ;)


good luck:(

TX.X-30 fan
06-04-2007, 12:07 AM
good luck:(




Thanks Milk, that information had never crossed my mind. :rolleyes: :D

TX.X-30 fan
06-04-2007, 12:09 AM
Edit: By the way Sir you are in need of a new wallet. 8p

88 PS190
06-04-2007, 12:13 AM
mmmm Zero Off! woo woo!

call them up, see what they think it could be.

beatle78
06-04-2007, 09:09 AM
well, I had a display break on my BU. One of the button stopped working. I updagraded to the new 6.5 display/firmware.

I did have a problem once were the perfect pass would reandomly reset on me while under way. Turns out there was a loose power wire that would wiggle around causing the reset.

There is a display cable that goes from the PP module to your display. That could have come loose, or your display could have just died.

The only other thing I could think of if there could be a problem with the pp module itself.

Since it was choppy, my bet is on a loose power wire.

the legend
06-04-2007, 10:57 AM
Did you notice the voltage gauge reading @ or below 11.5v. The alarm indicates that your battery voltage is low and thats why your perfect pass went out, it needs +- 11v to operate properly. Check your alternator wiring and batteries.The perfect pass took a crap this weekend. Warning buzzer was going off and the display had black bars half way across the screen. It was probably 10 min later the unit went dead completely. The water was a little choppy and I hope its just a connection somewhere but everything was so hot back there I didn't look much. I left the boat at TSR in New Braunfels. Just wanted to sound intelligent when I talk to the service guy tomorrow. I know very little about these units. Any help would be appreciated. ;)

TX.X-30 fan
06-04-2007, 12:41 PM
Did you notice the voltage gauge reading @ or below 11.5v. The alarm indicates that your battery voltage is low and thats why your perfect pass went out, it needs +- 11v to operate properly. Check your alternator wiring and batteries.



I have a digital regulator and the alt was sending 13.5 to the batteries. The gauge read straight up 13.??? The alarm I believe can also mean other stuff, Oil pressure, engine overheating ect. When the unit went blank completely the warning buzzer stopped, all other gauges read good. They should be calling soon, Ill let ya'll know
Thanks for the input(except of course you Milk :D ).

beatle78
06-04-2007, 02:01 PM
def keep us posted. I post all of this info in my memory banks for the day that I might have a similar problem

Cottonwood
06-04-2007, 04:09 PM
Also, there is a small 5amp inline fuse that could blow. You can't put a regular automotive 5amp - you have to go to Radio Shack for the fuse. I keep an extra one in the boat just in case it goes again.

TX.X-30 fan
06-08-2007, 06:17 PM
Picked up the boat and my 7yr son from camp at Texas Ski Ranch. The folks there made sure those kids had a great time. What a kids dream come true for a week at camp.

Anyway about the Perfect Pass, the guy told me there must be a loose nut behind the wheel :D no really, luckily just a loose connection that was simple to repair. :)

I was hoping to see some of the pro wakeskate guys but I guess we were to early. There is some kind of competition this weekend.

stevenm2
06-08-2007, 07:49 PM
I am glad to hear it was'nt serious.
It's good to know milk can afford a new wallet.

TX.X-30 fan
06-08-2007, 08:10 PM
I am glad to hear it was'nt serious.
It's good to know milk can afford a new wallet.



Thanks stevenm2, was very glad not to have a new wakeboard pro to pay for. :o 8p

beatle78
06-08-2007, 08:19 PM
nice, a lot of times it turns out to be something simple....

Maristar210
06-08-2007, 09:42 PM
Karma .... Smart boy :D :D :D