PDA

View Full Version : 2003 Horn dead?


kyfooter
05-31-2007, 10:58 PM
I have a 2003 197 now with a non-working horn. It worked last year, but now I have nothing.

I have already checked the connection in the dash itself, the breaker appears fine, and the connection to the horn itself is solid. What am I missing? There are only a few components to making a horn work.

Is there a fuse somewhere? If someone tells me it's in the breaker board, please tell me how to get the rubber caps off the breaker board.

Thanks. I realize it's just a horn, but it would be my luck to get stopped next time out and get a ticket for not having a working horn.

mrG
06-01-2007, 12:46 AM
I have a 2003 197 now with a non-working horn. It worked last year, but now I have nothing.

I have already checked the connection in the dash itself, the breaker appears fine, and the connection to the horn itself is solid. What am I missing? There are only a few components to making a horn work.

Is there a fuse somewhere? If someone tells me it's in the breaker board, please tell me how to get the rubber caps off the breaker board.

Thanks. I realize it's just a horn, but it would be my luck to get stopped next time out and get a ticket for not having a working horn.


Sorry you are having trouble.
It could just about anything; bad connection, circuit breaker tripped, defective circuit breaker, defective horn, defective switch/button for the horn.
If you have a volt meter, start checking around and make sure you have 12v available to the circuit. Check for loose connections especially the ground wire. Check continuity in the opeation of the horn button etc... .
You get the idea; just start tracing out the circuit until you find the fault.

bepresto
06-01-2007, 01:05 AM
forget the horn, all you need is to throw.....empty.....beer cans or bottles at the jet-skiers anyways.