PDA

View Full Version : Navigation Light Issue


DrJ
05-23-2007, 10:41 AM
Thought I would throw this one out there and see if any of you could give advice. I have a 2004 X2 and have not needed the navigation lights until this past weekend. The bow light works fine but nothing on the tower light. Took the tower light off the next morning to find that the previous owner had cut the wires in the tower. I am assuming it was an honest mistake. Can anyone tell me how the wires should run through the tower? And what color the wires are under the dash where they come into the wiring harness? Any Help would be appreciated.

trickskier
05-23-2007, 11:24 AM
I can tell you from experience that if the wiring is missing from the tower. Running new wire is a bit of a task. You'll probably need to pull the dash and check the color of the wiring at the toggle switch......Good Luck..........

DrJ
05-24-2007, 04:37 PM
I guess what I am asking is if the navigation light wires run down the right or left side of the tower. I would assume the right but I just want to be sure.

Timbo126
05-24-2007, 05:45 PM
I got a 03 197 with the mini tower. I have had to replace this tower light a couple of times because it keeps getting knocked off by ropes. My wires run down on the right side and then go towards the front of the boat through the tower tubing. Then they come in behind the dash. The wires are blue and black.

DrJ
05-24-2007, 06:31 PM
Thanks for the info. Can you tell me if the wires enter the wiring harness under the dash or do they go straight to the switch?