PDA

View Full Version : X-15 or X owners Question


rstitson
04-29-2007, 01:25 PM
We have just taken possesion of our x-15. One of the items on the check list was to have the dealer position the sound panel between the bow and drivers console correctly. After taking it home yesterday, I check and it was all cockeyed as before. While cursing them out, I attempted to put it in place with no success, probably why they ignored it. Does anyone have any suggestions or have encounterd the same. It's a nice panel but does not seem to fit correctly. It is hinged in the middle and seem like it is supposed to stay in place through friction fit but their is no the right room to make it fit????? Any info would be appreciated

erkoehler
04-29-2007, 03:53 PM
It will stay in place when you get it in correctly, but is a true PITA to get it.

Sorry, but I am not sure how to explain how it goes.

rstitson
04-29-2007, 11:51 PM
Thanks for the response. At least now I know I have a chance. Been thinking about it off an on all day. When the rain stops will give it another try.

SoCalBrew
04-30-2007, 02:03 AM
Curious what sound the panel is that you are talking about... hope I didn't miss a detail on my boat that i should check out... especially if it has something to do with sound (what my career is)!

Tom

Jet
04-30-2007, 07:31 AM
rstitson,

I am curious about this as well, do you have pics to show what this is about ?

djhuff
04-30-2007, 08:01 AM
It's a panel that protects all of the electronics that is behind the dash from the front storage areas. It is a total PITA to get in there, but it does fit, and is a tight fit. You have to kind of get it close with it slightly bent in the middle, then press it in place, pushing on the hinged area to straighten it out while pushing it the rest of the way in place. (get the top in, then the bottom)

Be careful there aren't any wires in the way, I had a wiring harness that was laying down by the floor that was trying to get in the way, a few chioce words later and it stayed in place.

2QWICK
04-30-2007, 08:40 AM
It CAN be done... my first time was tough but now i can do it in my sleep - hang in there.

rstitson
04-30-2007, 04:44 PM
Thanks, Just starting to stop raining around here, so will get to it tommorow.With all the electronics back there I had to take a break before I broke something. Have already popped out the vent for the drivers heater and am having fun trying to put that back. My son decide he would control the vents with his toe while driving. There is a two piece plastic fitting that hold the vent. You have to put you fingers through the open vent to attach the mating piece. I was trying to figure out how to put it in place and managed to attach it without the louvers in place. Now I am having a hard time getting it out.... Oh well, Seems I will find all the little gotchas soon.

ProTour X9
04-30-2007, 07:18 PM
You know, I might have this problem, probably not, but here goes: numerous times my speedos, tach, etc. and the LCD display say and have "NO DATA", its kinda scary cause theres 2 wires by my feet that don't plug into eachother. When i hit something up there with my feet it gets data for a while and then: "NO DATA". Its getting on my nerves!