PDA

View Full Version : Ruuu Rooo Shaggy


Doug G
04-08-2007, 09:44 PM
So last season the dearly beloved bumped the ballast pump switch and it then ran for several hours while tied up at the vacation house until she asked me to come look what the humming noise was. It worked, but was weak, for the rest of the season figured the impeller was hosed.

Finally swapped it out this weekend. Indeed it is hosed. Where did the missing parts go? Do I need to find them or did they just pass through? I am still garage bound by the weather so I haven't had a chance to run it yet.

BTW the engineer that put designed that setup should be smacked. Why they couldn't be mounted with the impeller access on the top is beyond me!

jrcarte78
04-11-2007, 10:05 AM
I think you could save that one and use it as a spare! ;) :D

DanC
04-11-2007, 01:22 PM
Where did the missing parts go?
Either in the hoses, in the bag, or out into the river. Before tearing things apart I would check the water flow rate. A more cautious man would pull all the hoses off and blow them out.


BTW the engineer that put designed that setup should be smacked. Why they couldn't be mounted with the impeller access on the top is beyond me!
The pumps recommend not mounting them with the impeller on top. My guess is either the bearings run better/longer that way or they don't want a water leak to leak onto the motor.

djhuff
04-11-2007, 01:59 PM
The pumps recommend not mounting them with the impeller on top. My guess is either the bearings run better/longer that way or they don't want a water leak to leak onto the motor.

Than why are two of the three mounted with the impeller on top??? (my X30 was the same way as my X2)

DanC
04-11-2007, 02:14 PM
Than why are two of the three mounted with the impeller on top??? (my X30 was the same way as my X2)

You got me:noface: I didn't say you should or shouldn't, I just said what the pump mfg recommended.
My pump installation papers say "Do not secure the pump in a position with the motor facing down."
Like I said, I'm just guessing as to the reason (also known as pulling it out of my a$$)
(I try to keep facts and my opinions identified as such)

Doug G
04-11-2007, 05:23 PM
Mine has 1 of 3 with the impeller on top. Sounds like a not so tightly controlled install process????????

dmayer84
04-11-2007, 09:47 PM
Mine has 1 of 3 with the impeller on top. Sounds like a not so tightly controlled install process????????

mine are the same way. I think its for the way that the pipes are run so that there is less of a chance of a kink.