PDA

View Full Version : Busted Blade


yzwiley
03-18-2007, 12:26 AM
Took the boat out for the first time this year and lost a prop blade. We hit nothing. The boat just started vibrating bad. I pulled it out of the water and find that I'm missing a blade.

What should I replace it with? The boat is an '04 X7 with the 310HP motor. The prop on it now reads 12.5 x 12v TC OJ.

yzwiley
03-18-2007, 12:28 AM
Pic #2 .

erkoehler
03-18-2007, 01:48 AM
WOW, I sent you a PM w/ some info that might help you out.

KnoxX2
03-18-2007, 02:38 AM
Talk to OJ might be a bad prop. Eric is a great guy to work with!

JohnnyB
03-18-2007, 08:29 AM
I'm not a metallurgist, but looking at the break surface leads me to believe there could be a material flaw there. I'm sure OJ will stand behind it.

TMCNo1
03-18-2007, 08:33 AM
Do as KnoxX2 said!
X2momma had the same happen and Eric @ OJ responded with this post, http://www.tmcowners.com/teamtalk/showpost.php?p=316374&postcount=30 from this thread, http://www.tmcowners.com/teamtalk/showthread.php?t=14862
Call him @ 1-800-359-9730 and tell him of your problem and refer him to this thread for reference.

ski_king
03-18-2007, 08:59 AM
Good pictures! They tell a lot, looks like a material flaw to me.

yzwiley
03-18-2007, 12:45 PM
Wow, I'm glad I'm a computer geek, as too I'm stoked with this board again.

Eric from Johnson Propeller sent me a PM. Said to send him the prop. That's a great company. Gives me the warm fuzzies inside knowing that there are such good folks out there standing behind their products.

SKI*MC
03-18-2007, 01:49 PM
It looks like part of it was cracked for a while, but by looking at how part of it is tarnished on the inside there, maybe a hairline crack from hitting something at a prior time. Have you ever hit anything?

yzwiley
03-18-2007, 02:24 PM
Have you ever hit anything?

Not that I'm aware of. The blades have always been straight and ding-free. I bought the boat as "new" too.

yzwiley
03-28-2007, 02:12 PM
Update: OJ Propellers took good care of me. Those folks are incredible.

Thank you OJ Props!!!

M-Funf
03-28-2007, 02:16 PM
It looks like part of it was cracked for a while, but by looking at how part of it is tarnished on the inside there, maybe a hairline crack from hitting something at a prior time. Have you ever hit anything?

I agree with SKI*MC. That green area has seen water for some time. May have been a crack, but could also have been a mfg. defect. I'd get it back to the manufacturer. If it was a defect from manufacturing, they'll want to know about it...

yzwiley
03-28-2007, 02:46 PM
I agree with SKI*MC. That green area has seen water for some time. May have been a crack, but could also have been a mfg. defect. I'd get it back to the manufacturer. If it was a defect from manufacturing, they'll want to know about it...

The manufacturer has the broken propeller and has sent me a new one. The manufacturer took REALLY good care of me. I'm very happy.

Who knows what the problem was. At this point I don't care. I'm just so happy OJ is a quality company and I think you all should know what great folks they are.

M-Funf
03-28-2007, 03:08 PM
I think it would be very helpful to know what the problem was, so if I had an OJ prop, I could look for any defects in an area of concern. That said, I think I know where to look from your pictures.

Glad to hear that OJ did you good on this...

Ryan27r
03-28-2007, 05:27 PM
This happened to my cousins 04 X9. They lost 2 or 3 blades though. The thing was a 21 foot floating vibrator right when it happened.

Footin
03-28-2007, 06:28 PM
Nice to hear the OJ fixed your problem. IIRC Eric from OJ is on hear occasionally.

h20winn
03-29-2007, 02:08 AM
How about some contact information for OJ? Is there a name of a person that you talked to?

erkoehler
03-29-2007, 02:11 AM
Eric from OJ is who took care of the problem, he is a member here on TMC :)

Bobbyk
03-29-2007, 02:44 AM
Eric just hooked up a new prop for the 06 after a bad weekend. shipped it out ASAP and is fixin the old one. That guy Rocks.

TMCNo1
03-29-2007, 10:22 AM
How about some contact information for OJ? Is there a name of a person that you talked to?


See post #6, http://www.tmcowners.com/teamtalk/showpost.php?p=317907&postcount=6

boatless
03-29-2007, 11:26 AM
You are lucky that the blade did not damage the bottom of your boat. did you check yet ?

boatless

yzwiley
03-29-2007, 12:03 PM
You are lucky that the blade did not damage the bottom of your boat. did you check yet ?

boatless

Yeah, I checked. We got lucky I believe. But then again, I have insurance so I wasn't all that stressed.