PDA

View Full Version : Heater Stopped Blowing


sixysixss
01-23-2007, 02:03 PM
Had the boat out on the lake Saturday morning. As we were going back to the dock, I noticed that the heater had stopped working. I checked the breaker for the accessory switch and it was fine. The light on the switch was on, but the heater was not blowing any air. Any ideas? :confused:

Thanks. Rob

TMCNo1
01-23-2007, 02:09 PM
Had the boat out on the lake Saturday morning. As we were going back to the dock, I noticed that the heater had stopped working. I checked the breaker for the accessory switch and it was fine. The light on the switch was on, but the heater was not blowing any air. Any ideas? :confused:

Thanks. Rob


Sounds like the blower motor has gone bad! Pull it out and check to see if it runs just off the leads, if not, replace or reuild. A electric motor shop can also check it out and do a rebuild for you.

jkski
01-23-2007, 02:12 PM
Check for loose wires to start. There should only be 3 or 4 if memory serves. One of the wires may have come off the back of the switch, so check there first then proceed to follow them from the actual heater over to the dash area. Typically, everything is well labeled, so you'll know pretty quickly what goes to what.
If all the wires are connected and you still got nothin', you may have fried motor, at which point it may be smart to contact your dealer, seeing as how the boat is a 2005 and the heater should still be working fine.
Good luck.

sixysixss
01-23-2007, 02:49 PM
Thanks. I'll check all the connections and check the motor. If bad, back to the dealer.

trickskier
01-23-2007, 03:20 PM
Check your curcuit breaker to see if it has been tripped too. It should be right under the switch.