PDA

View Full Version : Shower Question - Cold Water Pressure


sixysixss
10-04-2006, 02:37 PM
I have a question about the shower in my '05 X9. The hot water flows great, but the cold water seems to flow at just a trickle. I took the cold water hose off to check for blockage or kinks, but it all appears to be clear. I notice that the cold water line is teed into the intake line after the raw water impeller. Does this prevent it from getting cold water if the motor is not running? Or, to put it another way, does the motor have to be running in order to properly operate the shower? If so, has anyone replumbed the shower to another fresh water source? Thanks. Rob

jmac197
10-04-2006, 02:43 PM
I put my cold water Tee in the raw water intake hose between the raw water intake at the hull and the raw water pump at the front of the engine.

I figured the shower pump would be able to pull water from the lake without help from the raw water pump. Plus if you are cleaning the boat or something nearby, you don't have to have the engine running. That is if you don't need warm water.

Later
Jim

sixysixss
10-04-2006, 03:44 PM
Jim, does this allow your shower to pump cold water at 1 GPM or whatever the pump is rated for? I assume that by plumbing it this way you haven't had any issues with inadequate flow from the cold water? Thanks. Rob

jmac197
10-04-2006, 03:52 PM
Yes I can pump a pretty good stream of cold water this way.

BTW did you check the screen in the mixing valve? I've had that plug up pretty tight.