PDA

View Full Version : engine decelration at high rpms


Lake Watagua VOL
09-07-2006, 11:15 AM
Just noticed this weekned on my 83 S7S that whne running at full throttle, the boat will suddenly decelrate to 1500 or 2000 rms. This occurs fairly incosistently. All I can think is bad feul or filter or lack of air to the engine. I cleaned the air filter but have not been able to try it out yet. Anyone else ever had this problem? Thanks

east tx skier
09-07-2006, 11:26 AM
How about the fuel filter? When was it last replaced?

Jwhitsett1129
09-07-2006, 12:01 PM
I was experiencing similar issues a while back. I wasn't quite at WOT, but it only happened at RPM's above 3500. I ran some Sea Foam through my gas tank and have not had a problem since...

CoFooter
09-07-2006, 12:29 PM
Fuel Filter.......... Had the same problem with surging at high RPM's. Replaced it - problem gone.

Jwhitsett1129
09-07-2006, 12:32 PM
I feel like an idiot for asking, but where is the fuel filter on these boats?

Tryin-again
09-07-2006, 12:37 PM
Did you check the temp guage?

Our raw water filter (at the tranny cooler line) got clogged and while towing a skier it got hot - didn't realize it and the motor killed itself to about that RPM.... we could run slow fine - didn't need as much water - but it would heat at speed.. We limped it in... :(

Cleaned the filter- no problem since..... although I clean it about once a month now.... :rolleyes:

Lake Watagua VOL
09-07-2006, 12:39 PM
At least 2 yrs ago. Probably that. I'll try it out. Thanks

east tx skier
09-07-2006, 02:23 PM
I feel like an idiot for asking, but where is the fuel filter on these boats?

On your 88, there should be an element inside a little black canister just to the starboard of the fuel pump. There's a good diagram of it in the owner's manual available on www.mastercraft.com. There's also a direct link to the page with the owners manauals on it in the FAQ setion or in Pendo's signature.